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When Customizing a Template, Some Fonts are not Displayed in the Template Editor

Symptom

When customizing styles in the Styles section of the template editor, it is not possible to view specific fonts in the live-preview window. A browser specific message notifying users of this potential behaviour is displayed in the template editor. This example is shown when using Mozilla Firefox:  

Cause

Due to the limitations of some internet browsers this can occur because:

  • The browser does not support web fonts – both Internet Explorer and Microsoft Edge internet browsers do not support the preview of different web fonts. This means that fonts included with the app, as well as custom fonts which are uploaded, will not be previewable in the template editor. 
  • The browser does not support the file format for the chosen font – due to bugs in Google Chrome and Safari internet browsers, weights and styles (normal / bold / italic) of .ttc font files might be previewed incorrectly
  • The browser only supports a specific format of the font – due to restrictive font validation rules in Mozilla Firefox, some font files might not preview correctly

Resolution 

Even though the internet browser might not correctly display a font in the template editor, Scroll PDF Exporter will use the font selected in the customized template and render it in the PDF export. 

If you are wishing to see how the custom font is displayed in the template editor, using a different internet browser can often fix the issue. However, please take into consideration the above mentioned information for each internet browser. 


JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.