Skip to main content
Skip table of contents

Can't Find Page in Create Context Key Dialog

Problem

The search in the “Create Context Key” dialog can’t find the page I’m searching for.

Solution

As an attempt to resolve the issue, follow the steps below:

  1. Navigate to the Document Manager of the affected Scroll Document.

  2. Click More document actions (•••)

  3. Select Advanced options

  4. Click Manage page groups:

If

Solution

…the page you are searching for is listed under “Pages without a page group.”

  1. Click Auto-Group to assign the page to a page group.

  2. Wait for the dialog to finish loading.

  3. Click Close to get back to the Document Manager.

  4. Click Manage.

  5. Select Context Keys.

  6. Click Add new key and try searching for the page again.

…the page cannot be found under “Pages without a page group.”

Go back to the page tree of your Scroll Document and double check if the page actually is a part of the document. If the page exists within the document but you still can’t search for it, contact support for help with troubleshooting via: help@K15t.com

Cause

If the page was found under the column “Pages without a page group” in the Page group manager, then it’s likely this page was added to an already saved document version.

If a page is created or added to an already saved version (not the Working version), the page won’t have a Scroll Page ID assigned to it, which means it’s not yet officially a part of the document. As a consequence, the page can’t be found by the search in the “Create Context Key” dialog. To give the page a Scroll Page ID it needs to be added to a page group in the Page group manager.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.