This article explains what versions of Jira can be synchronized with one another using Backbone Issue Sync.

Server ↔ Server

Backbone Issue Sync supports Jira Server versions 7.0 and higher. All supported versions can be synchronized with each other – e.g. you can synchronize a Jira 7.0 instance with a Jira 8.x instance.

We suggest to read the related example use cases, e.g. how to setup a bidirectional synchronization.

If you are using Jira 6.3 or 6.4, we strongly recommend that you upgrade to a current Jira version since Jira 6.3/6.4 have reached their end of life in July 2016/March 2017. If you still want to synchronize with such a Jira, you can install Backbone 3.9.2 on that instance and configure the synchronization in another instance which should be a supported Jira version. Please note that we don't explicitly test this scenario, so future updates may break this compatibility.

Server ↔ Cloud or Cloud ↔ Server

Example Use Case article

Cloud ↔ Cloud

in the cloud section of our documentation.how to setup a bidirectional synchronization